diff mbox series

[bug#53019,4/6] gnu: Add python-pytest-cov-3.0.

Message ID 20220701213302.13234-4-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/6] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi July 1, 2022, 9:33 p.m. UTC
* gnu/packages/check.scm (python-pytest-cov-3.0): New variable.
---
 gnu/packages/check.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

M July 30, 2022, 9:09 p.m. UTC | #1
On 01-07-2022 23:33, Giacomo Leidi via Guix-patches via wrote:
> +(define-public python-pytest-cov-3.0
> +  (package
> +    (inherit python-pytest-cov)
Likewise as for python-coverage-5.5, why the separate package?
iyzsong--- via Guix-patches via July 30, 2022, 10:52 p.m. UTC | #2
Dear Maxime,
> Likewise as for python-coverage-5.5, why the separate package?
Both python-pytest-cov and python-coverage have a lot of dependents, 
they must be updated on staging...

$ guix refresh --list-dependent python-pytest-cov
Building the following 521 packages would ensure 1172 dependent packages 
are rebuilt: python-pysox [...]

$ guix refresh --list-dependent python-coverage
Building the following 627 packages would ensure 1408 dependent packages 
are rebuilt: u-boot-puma-rk3399 [...]\

I sent a patch for python-pytest-cov back in march, 
(https://git.savannah.gnu.org/cgit/guix.git/commit/?h=staging&id=12c9da35389dfba86ae0d863132a6b2c4374205a) 
but I didn't manage to find the time to do it also for python-coverage.

Thank you,

Giacomo
M July 30, 2022, 11:13 p.m. UTC | #3
On 31-07-2022 00:52, goodoldpaul@autistici.org wrote:
> Dear Maxime,
>> Likewise as for python-coverage-5.5, why the separate package?
> Both python-pytest-cov and python-coverage have a lot of dependents, 
> they must be updated on staging...

Then you can mention that in the commit message, or better, ask for 
someone to merge staging (it's not core-updates) into master ...

>
> $ guix refresh --list-dependent python-pytest-cov
> Building the following 521 packages would ensure 1172 dependent 
> packages are rebuilt: python-pysox [...]
>
> $ guix refresh --list-dependent python-coverage
> Building the following 627 packages would ensure 1408 dependent 
> packages are rebuilt: u-boot-puma-rk3399 [...]\
>
> I sent a patch for python-pytest-cov back in march, 
> (https://git.savannah.gnu.org/cgit/guix.git/commit/?h=staging&id=12c9da35389dfba86ae0d863132a6b2c4374205a) 


... mentioning this in the commit message would avoid having the 
reviewer doing some pointless checking whether the new version doesn't 
contain malware, whether it builds reproducibly, etc, as it was 
presumably already done for the staging patch.

Greetings,
Maxime.
iyzsong--- via Guix-patches via Oct. 10, 2022, 9:29 p.m. UTC | #4
Dear Maxime,
On 2022-07-30 23:13, Maxime Devos wrote:
> ... mentioning this in the commit message would avoid having the
> reviewer doing some pointless checking whether the new version doesn't
> contain malware, whether it builds reproducibly, etc, as it was
> presumably already done for the staging patch.

I sent a patch to staging ( https://issues.guix.gnu.org/58421 ) and I 
should have addressed all your comments. I'm sending an updated patch 
set.

Thank you for your time,

giacomo
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 58af53388e..51fa2d2282 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1089,6 +1089,17 @@  (define-public python-pytest-cov
 supports coverage of subprocesses.")
   (license license:expat)))
 
+(define-public python-pytest-cov-3.0
+  (package
+    (inherit python-pytest-cov)
+    (version "3.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pytest-cov" version))
+        (sha256
+         (base32 "0w6lfv8gc1lxmnvsz7mq5z9shxac5zz6s9mwrai108kxc6qzbw77"))))))
+
 (define-public python-pytest-httpserver
   (package
     (name "python-pytest-httpserver")