diff mbox series

[bug#48729,v7,06/25] gnu: Add go-github-com-sevlyar-go-daemon.

Message ID 20210701021841.2954-6-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48729,v7,01/25] gnu: Add go-github-com-rakyll-statik. | expand

Commit Message

Raghav Gururajan July 1, 2021, 2:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-sevlyar-go-daemon): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Tobias Geerinckx-Rice July 3, 2021, 2:15 a.m. UTC | #1
Raghav Gururajan via Guix-patches via 写道:
> +    (description "Go-Daemon is a library for writing system 
> daemons in golang.")

s/golang/Go/ anywhere, any time, any place.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ac48b41f97..d715c76a7f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -73,6 +73,30 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-sevlyar-go-daemon
+  (package
+    (name "go-github-com-sevlyar-go-daemon")
+    (version "0.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/sevlyar/go-daemon")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y3gnxaifykcjcbzx91lz9bc93b95w3xj4rjxjbii26pm3j7gqyk"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/sevlyar/go-daemon"))
+    (propagated-inputs
+     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+    (home-page "https://github.com/sevlyar/go-daemon")
+    (synopsis "Library for writing system daemons")
+    (description "Go-Daemon is a library for writing system daemons in golang.")
+    (license license:expat)))
+
 (define-public go-github-com-keybase-go-ps
   (let ((commit "91aafc93ba19d1988cff338c1929d35b6c6f5b50")
         (revision "45"))