diff mbox series

[bug#48729,v7,03/25] gnu: Add go-github-com-emersion-go-autostart.

Message ID 20210701021841.2954-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48729,v7,01/25] gnu: Add go-github-com-rakyll-statik. | expand

Commit Message

Raghav Gururajan July 1, 2021, 2:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-emersion-go-autostart): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Tobias Geerinckx-Rice July 3, 2021, 1:57 a.m. UTC | #1
Raghav Gururajan via Guix-patches via 写道:
> +(define-public go-github-com-emersion-go-autostart
> +  (let ((commit "00ed301c8e9ae79e82878c6361c709983ac5dd2c")
> +        (revision "39"))

Just use 0 here.  I suspect you counted the number of commits 
(some distros do this), but we don't care: it's just a number that 
gets incremented by 1 every time someone bumps the commit by 
however many.

This applies to all similar patches in the series.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b1c909ac53..fc5d161b39 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -73,6 +73,30 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-emersion-go-autostart
+  (let ((commit "00ed301c8e9ae79e82878c6361c709983ac5dd2c")
+        (revision "39"))
+    (package
+      (name "go-github-com-emersion-go-autostart")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/emersion/go-autostart")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0cqqvbzn32xv5lknfygrx01rx2sc6pi833k7008nlk9lsfgry06v"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/emersion/go-autostart"))
+      (home-page "https://github.com/emersion/go-autostart")
+      (synopsis "Autostart library in Go")
+      (description "Go-Autostart is a Go library to run a command after login.")
+      (license license:expat))))
+
 (define-public go-github-com-dchest-siphash
   (package
     (name "go-github-com-dchest-siphash")