diff mbox series

[bug#48729,v7,14/25] gnu: Add go-github-com-operatorfoundation-monolith-go.

Message ID 20210701021841.2954-14-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48729,v7,01/25] gnu: Add go-github-com-rakyll-statik. | expand

Commit Message

Raghav Gururajan July 1, 2021, 2:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-operatorfoundation-monolith-go): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5438f358f5..0e9c0f3a8c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -73,6 +73,33 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-operatorfoundation-monolith-go
+  (package
+    (name "go-github-com-operatorfoundation-monolith-go")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/OperatorFoundation/monolith-go")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "066bqlgw5h7a3kxswqlv734asb7nw2y6snsn09yqk0ixj23qw22s"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:tests? #f ; ERROR: Generated bytes do not match correct answer.
+       #:unpack-path "github.com/OperatorFoundation/monolith-go"
+       #:import-path "github.com/OperatorFoundation/monolith-go/monolith"))
+    (propagated-inputs
+     `(("go-github-com-deckarep-golang-set"
+        ,go-github-com-deckarep-golang-set)))
+    (home-page "https://github.com/OperatorFoundation/monolith-go")
+    (synopsis "Byte sequences library")
+    (description "Monolith-Go is a Go library for working with byte sequences.")
+    (license license:expat)))
+
 (define-public go-github-com-deckarep-golang-set
   (package
     (name "go-github-com-deckarep-golang-set")