diff mbox series

[bug#48729,v7,01/25] gnu: Add go-github-com-rakyll-statik.

Message ID 20210701021841.2954-1-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48729,v7,01/25] gnu: Add go-github-com-rakyll-statik. | expand

Commit Message

Raghav Gururajan July 1, 2021, 2:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-rakyll-statik): New variable.

Co-authored-by: jgart <jgart@dismail.de>
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Tobias Geerinckx-Rice July 3, 2021, 1:56 a.m. UTC | #1
Raghav Gururajan via Guix-patches via 写道:
> +your Go binary to be later served from an http.")

‘HTTP’, and it sounds like the sentence got cut off?

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aedb5d4f69..8c53a02aa3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -27,6 +27,8 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@mgail.com>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -71,6 +73,29 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-rakyll-statik
+  (package
+    (name "go-github-com-rakyll-statik")
+    (version "0.1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/rakyll/statik")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0y0kbzma55vmyqhyrw9ssgvxn6nw7d0zg72a7nz8vp1zly4hs6va"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/rakyll/statik"))
+    (home-page "https://github.com/rakyll/statik/")
+    (synopsis "Embed files into a Go executable")
+    (description "Statik allows you to embed a directory of static files into
+your Go binary to be later served from an http.")
+    (license license:asl2.0)))
+
 ;; According to https://golang.org/doc/install/gccgo, gccgo-4.8.2 includes a
 ;; complete go-1.1.2 implementation, gccgo-4.9 includes a complete go-1.2
 ;; implementation, and gccgo-5 a complete implementation of go-1.4.  Ultimately