diff mbox series

[bug#37988,4/6] gnu: Add r-cytolib.

Message ID 20191030102531.12495-4-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add flowWorkspace from BioConductor | expand

Commit Message

Simon Tournier Oct. 30, 2019, 10:25 a.m. UTC
* gnu/packages/bioconductor.scm (r-cytolib): New variable.
---
 gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ricardo Wurmus Oct. 30, 2019, 11:41 a.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> * gnu/packages/bioconductor.scm (r-cytolib): New variable.
[…]
> +    (synopsis "C++ infrastructure for representing and interacting
> with the gated cytometry")

I would remove “the” from “the gated cytometry”.  How about
“Infrastructure for working with gated cytometry data”?

> +    (description "This package provides the core data structure and API to
> +represent and interact with the gated cytometry data.")

Here I’d also remove “the”.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7c1761852c..a5c6e1ed55 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6205,3 +6205,26 @@  data.")
     (description "This package provides the headers and static library of
 Protocol buffers 2.6.0 for other R packages to compile and link against.")
     (license license:bsd-3)))
+
+(define-public r-cytolib
+  (package
+    (name "r-cytolib")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "cytolib" version))
+       (sha256
+        (base32
+         "10sdkwrmzmp3sh59hl3x0zxwlw77v80jnv8gz1qrv66skjb764cq"))))
+    (properties
+     `((upstream-name . "cytolib")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-rprotobuflib" ,r-rprotobuflib)))
+    (home-page "https://bioconductor.org/packages/cytolib")
+    (synopsis "C++ infrastructure for representing and interacting with the gated cytometry")
+    (description "This package provides the core data structure and API to
+represent and interact with the gated cytometry data.")
+    (license license:artistic2.0)))