diff mbox series

[bug#37988,1/6] gnu: Add r-idpmisc.

Message ID 20191030102531.12495-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add flowWorkspace from BioConductor | expand

Commit Message

Simon Tournier Oct. 30, 2019, 10:25 a.m. UTC
* gnu/packages/cran.scm (r-idpmisc): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b16b96dc77..f47eafc3bb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15653,3 +15654,32 @@  unique identifiers, and whether it is a certain length.  In addition,
 files and to efficiently import multiple tabular data files into one
 data.table.")
     (license license:gpl3)))
+
+(define-public r-idpmisc
+  (package
+    (name "r-idpmisc")
+    (version "1.1.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "IDPmisc" version))
+       (sha256
+        (base32
+         "13qcvfm703frs367paddz1wq9k3p17f9p5347m56bhky5hjkaphd"))))
+    (properties
+     `((upstream-name . "IDPmisc")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)))
+    (home-page "https://cran.r-project.org/web/packages/IDPmisc")
+    (synopsis "Miscellaneous tools of Institute of Data Analyses and Process Design")
+    (description "This package provides different high-level graphics
+functions for displaying large datasets and circular data in a very flexible
+way, finding local maxima, brewing color ramps, drawing nice arrows, zooming
+2D-plots, creating figures with differently colored margin and plot region.
+In addition, the package contains auxiliary functions for data manipulation
+like omitting observations with irregular values or selecting data by logical
+vectors, which include NAs.  Other functions are especially useful in
+spectroscopy and analyses of environmental data: robust baseline fitting,
+finding peaks in spectra, converting humidity measures.")
+    (license license:gpl3+)))