diff mbox series

[bug#37988,6/6] gnu: Add r-flowworkspace.

Message ID 20191030102531.12495-6-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add flowWorkspace from BioConductor | expand

Commit Message

Simon Tournier Oct. 30, 2019, 10:25 a.m. UTC
* gnu/packages/bioconductor.scm (r-flowworkspace): New variable.
---
 gnu/packages/bioconductor.scm | 50 +++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2636095e0f..dabfcb2cb3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6260,3 +6260,53 @@  represent and interact with the gated cytometry data.")
      "This package provides HDF5 storage based methods and functions for
 manipulation of flow cytometry data.")
     (license license:artistic2.0)))
+
+(define-public r-flowworkspace
+  (package
+    (name "r-flowworkspace")
+    (version "3.32.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "flowWorkspace" version))
+       (sha256
+        (base32
+         "1r1xxqzlp2x2gf79f37ckninnyjkxcb7xz7rffg2nadmapl5shvw"))))
+    (properties
+     `((upstream-name . "flowWorkspace")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-cytolib" ,r-cytolib)
+       ("r-data-table" ,r-data-table)
+       ("r-digest" ,r-digest)
+       ("r-dplyr" ,r-dplyr)
+       ("r-flowcore" ,r-flowcore)
+       ("r-flowviz" ,r-flowviz)
+       ("r-graph" ,r-graph)
+       ("r-gridextra" ,r-gridextra)
+       ("r-lattice" ,r-lattice)
+       ("r-latticeextra" ,r-latticeextra)
+       ("r-matrixstats" ,r-matrixstats)
+       ("r-ncdfflow" ,r-ncdfflow)
+       ("r-rbgl" ,r-rbgl)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcppparallel" ,r-rcppparallel)
+       ("r-rgraphviz" ,r-rgraphviz)
+       ("r-rprotobuflib" ,r-rprotobuflib)
+       ("r-scales" ,r-scales)
+       ("r-stringr" ,r-stringr)))
+    (home-page
+     "https://bioconductor.org/packages/flowWorkspace")
+    (synopsis "Infrastructure for representing and interacting with cytometry data sets")
+    (description
+     "This package provides importer for basic workspaces from the proprietary
+software FlowJo into the BioConductor package flowCore.  It is designed to
+facilitate comparison of automated gating methods against manual gating.
+Gating hierarchies, groups of samples, compensation, and transformation are
+performed so that the output matches the analysis from the proprietary
+software FlowJo.")
+    (license license:artistic2.0)))