[bug#75068,rust-team,v2,87/93] gnu: rust-pyo3-0.21: Order alphabetically.

Message ID f8b16a909cbe1ecd0573af1268098879b7aa4979.1735070699.git.herman@rimm.ee
State New
Headers
Series Order (gnu packages crates-io) up to |

Commit Message

Herman Rimm Dec. 24, 2024, 8:11 p.m. UTC
  * gnu/packages/crates-io.scm (rust-pyo3-0.21): Order.

Change-Id: I6d025a59ffabe79930169b2d4e447c661091b9fb
---
 gnu/packages/crates-io.scm | 94 +++++++++++++++++++-------------------
 1 file changed, 47 insertions(+), 47 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b05c0a44ad..98622138d5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -63656,6 +63656,53 @@  (define-public rust-pyo3-0.22
         ("rust-static-assertions" ,rust-static-assertions-1)
         ("rust-trybuild" ,rust-trybuild-1))))))
 
+(define-public rust-pyo3-0.21
+  (package
+    (inherit rust-pyo3-0.22)
+    (name "rust-pyo3")
+    (version "0.21.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pyo3" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1n39y183jfqbyvimscqr0ysxxa6804pn46ivw048ww91lnb0pq55"))))
+    (arguments
+     `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+                       ("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-chrono" ,rust-chrono-0.4)
+                       ("rust-chrono-tz" ,rust-chrono-tz-0.6)
+                       ("rust-either" ,rust-either-1)
+                       ("rust-eyre" ,rust-eyre-0.6)
+                       ("rust-hashbrown" ,rust-hashbrown-0.14)
+                       ("rust-indexmap" ,rust-indexmap-2)
+                       ("rust-indoc" ,rust-indoc-2)
+                       ("rust-inventory" ,rust-inventory-0.3)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-memoffset" ,rust-memoffset-0.9)
+                       ("rust-num-bigint" ,rust-num-bigint-0.4)
+                       ("rust-num-complex" ,rust-num-complex-0.4)
+                       ("rust-parking-lot" ,rust-parking-lot-0.12)
+                       ("rust-portable-atomic" ,rust-portable-atomic-1)
+                       ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.21)
+                       ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.21)
+                       ("rust-pyo3-macros" ,rust-pyo3-macros-0.21)
+                       ("rust-rust-decimal" ,rust-rust-decimal-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-smallvec" ,rust-smallvec-1)
+                       ("rust-unindent" ,rust-unindent-0.2))
+       #:cargo-development-inputs (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
+                                   ("rust-chrono" ,rust-chrono-0.4)
+                                   ("rust-chrono-tz" ,rust-chrono-tz-0.6)
+                                   ("rust-futures" ,rust-futures-0.3)
+                                   ("rust-proptest" ,rust-proptest-1)
+                                   ("rust-rayon" ,rust-rayon-1)
+                                   ("rust-send-wrapper" ,rust-send-wrapper-0.6)
+                                   ("rust-serde" ,rust-serde-1)
+                                   ("rust-serde-json" ,rust-serde-json-1)
+                                   ("rust-trybuild" ,rust-trybuild-1))))))
+
 (define-public rust-pyo3-build-config-0.23
   (package
     (name "rust-pyo3-build-config")
@@ -64294,53 +64341,6 @@  (define-public rust-pyo3-macros-0.15
         ("rust-syn" ,rust-syn-1))))
     (native-inputs (list python))))
 
-(define-public rust-pyo3-0.21
-  (package
-    (inherit rust-pyo3-0.22)
-    (name "rust-pyo3")
-    (version "0.21.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "pyo3" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1n39y183jfqbyvimscqr0ysxxa6804pn46ivw048ww91lnb0pq55"))))
-    (arguments
-     `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
-                       ("rust-cfg-if" ,rust-cfg-if-1)
-                       ("rust-chrono" ,rust-chrono-0.4)
-                       ("rust-chrono-tz" ,rust-chrono-tz-0.6)
-                       ("rust-either" ,rust-either-1)
-                       ("rust-eyre" ,rust-eyre-0.6)
-                       ("rust-hashbrown" ,rust-hashbrown-0.14)
-                       ("rust-indexmap" ,rust-indexmap-2)
-                       ("rust-indoc" ,rust-indoc-2)
-                       ("rust-inventory" ,rust-inventory-0.3)
-                       ("rust-libc" ,rust-libc-0.2)
-                       ("rust-memoffset" ,rust-memoffset-0.9)
-                       ("rust-num-bigint" ,rust-num-bigint-0.4)
-                       ("rust-num-complex" ,rust-num-complex-0.4)
-                       ("rust-parking-lot" ,rust-parking-lot-0.12)
-                       ("rust-portable-atomic" ,rust-portable-atomic-1)
-                       ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.21)
-                       ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.21)
-                       ("rust-pyo3-macros" ,rust-pyo3-macros-0.21)
-                       ("rust-rust-decimal" ,rust-rust-decimal-1)
-                       ("rust-serde" ,rust-serde-1)
-                       ("rust-smallvec" ,rust-smallvec-1)
-                       ("rust-unindent" ,rust-unindent-0.2))
-       #:cargo-development-inputs (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
-                                   ("rust-chrono" ,rust-chrono-0.4)
-                                   ("rust-chrono-tz" ,rust-chrono-tz-0.6)
-                                   ("rust-futures" ,rust-futures-0.3)
-                                   ("rust-proptest" ,rust-proptest-1)
-                                   ("rust-rayon" ,rust-rayon-1)
-                                   ("rust-send-wrapper" ,rust-send-wrapper-0.6)
-                                   ("rust-serde" ,rust-serde-1)
-                                   ("rust-serde-json" ,rust-serde-json-1)
-                                   ("rust-trybuild" ,rust-trybuild-1))))))
-
 (define-public rust-pyo3-0.20
   (package
     (inherit rust-pyo3-0.21)