[bug#75068,rust-team,v2,42/93] gnu: rust-magma-0.8: Order alphabetically.

Message ID 8e18259d153a58597f6588f7ea49811529421153.1735070696.git.herman@rimm.ee
State New
Headers
Series Order (gnu packages crates-io) up to |

Commit Message

Herman Rimm Dec. 24, 2024, 8:10 p.m. UTC
  * gnu/packages/crates-io.scm (rust-magma-0.8): Order.

Change-Id: I5a690d001288e7c9aa86580d2d257aef1826e17a
---
 gnu/packages/crates-io.scm | 44 +++++++++++++++++++-------------------
 1 file changed, 22 insertions(+), 22 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ba54fcab01..48076d5013 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45048,28 +45048,6 @@  (define-public rust-macrotest-1
      "This package provides test harness for macro expansion in Rust.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-magma-0.8
-  (package
-    (name "rust-magma")
-    (version "0.8.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "magma" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32 "1w321p30599kc85bb35ps32ykqc9gzpi5b99dsw793nxrypnj9xb"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cipher" ,rust-cipher-0.4))
-       #:cargo-development-inputs
-       (("rust-cipher" ,rust-cipher-0.4)
-        ("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/block-ciphers")
-    (synopsis "Magma (GOST R 34.12-2015) block cipher")
-    (description "Magma (GOST R 34.12-2015) block cipher")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-magic-crypt-3
   (package
     (name "rust-magic-crypt")
@@ -45129,6 +45107,28 @@  (define-public rust-magic-string-0.3
      "This package provides a MagicString port driven by Rust and N-API.")
     (license license:expat)))
 
+(define-public rust-magma-0.8
+  (package
+    (name "rust-magma")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "magma" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "1w321p30599kc85bb35ps32ykqc9gzpi5b99dsw793nxrypnj9xb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cipher" ,rust-cipher-0.4))
+       #:cargo-development-inputs
+       (("rust-cipher" ,rust-cipher-0.4)
+        ("rust-hex-literal" ,rust-hex-literal-0.3))))
+    (home-page "https://github.com/RustCrypto/block-ciphers")
+    (synopsis "Magma (GOST R 34.12-2015) block cipher")
+    (description "Magma (GOST R 34.12-2015) block cipher")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-maildir-0.6
   (package
     (name "rust-maildir")