[bug#75068,rust-team,v2,74/93] gnu: rust-paw-structopt-1: Order alphabetically.

Message ID e47284bd50161e4f0381b7fd1bcbdbe74585a2be.1735070698.git.herman@rimm.ee
State New
Headers
Series Order (gnu packages crates-io) up to |

Commit Message

Herman Rimm Dec. 24, 2024, 8:11 p.m. UTC
  * gnu/packages/crates-io.scm (rust-paw-structopt-1): Order.

Change-Id: Ifed73bac99c7915887d98c910f801de4cb756b4a
---
 gnu/packages/crates-io.scm | 48 +++++++++++++++++++-------------------
 1 file changed, 24 insertions(+), 24 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8a1528e8f8..1b0b86a018 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56749,6 +56749,30 @@  (define-public rust-paw-raw-1
 implementations.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-paw-structopt-1
+  (package
+    (name "rust-paw-structopt")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "paw-structopt" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1iwg83xqjpfgpy8wrq173cy7zgkyxfryd230sh34f5qsjdx7zap4"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f      ; use of undeclared crate or module `paw`
+       #:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-0.4)
+        ("rust-quote" ,rust-quote-0.6)
+        ("rust-structopt" ,rust-structopt-0.2)
+        ("rust-syn" ,rust-syn-0.15))))
+    (home-page "https://github.com/rust-cli/paw")
+    (synopsis "Structopt support for the Paw crate")
+    (description "This package provides Structopt support for the Paw crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-pcap-1
   (package
     (name "rust-pcap")
@@ -78187,30 +78211,6 @@  (define-public rust-slab-0.4
 data type.")
     (license license:expat)))
 
-(define-public rust-paw-structopt-1
-  (package
-    (name "rust-paw-structopt")
-    (version "1.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "paw-structopt" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1iwg83xqjpfgpy8wrq173cy7zgkyxfryd230sh34f5qsjdx7zap4"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:tests? #f      ; use of undeclared crate or module `paw`
-       #:cargo-inputs
-       (("rust-proc-macro2" ,rust-proc-macro2-0.4)
-        ("rust-quote" ,rust-quote-0.6)
-        ("rust-structopt" ,rust-structopt-0.2)
-        ("rust-syn" ,rust-syn-0.15))))
-    (home-page "https://github.com/rust-cli/paw")
-    (synopsis "Structopt support for the Paw crate")
-    (description "This package provides Structopt support for the Paw crate.")
-    (license (list license:expat license:asl2.0))))
-
 ;; TODO: Unbundle sleef.
 (define-public rust-sleef-sys-0.1
   (package