diff mbox series

[bug#69170,rust-team,34/46] gnu: Add rust-dhcproto-0.9.

Message ID f63376afd55deabb6facbbd4618a07c9c974fa8b.1708028702.git.~@wolfsden.cz
State New
Headers show
Series Add netavark | expand

Commit Message

Tomas Volf Feb. 15, 2024, 8:26 p.m. UTC
* gnu/packages/crates-io.scm (rust-dhcproto-0.9): New variable.

Change-Id: Iac0f123908885695d14a71bcf32cc2658af2d013
---
 gnu/packages/crates-io.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 82caf5b1c6..f967f96224 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18972,6 +18972,36 @@  (define-public rust-dhcproto-macros-0.1
 dhcproto.")
     (license license:expat)))
 
+(define-public rust-dhcproto-0.9
+  (package
+    (name "rust-dhcproto")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "dhcproto" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1hsbl77lxvxa94ihn2vna1sx2icrkch427w24a883xymhm9h9vnw"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-dhcproto-macros" ,rust-dhcproto-macros-0.1)
+                       ("rust-hex" ,rust-hex-0.4)
+                       ("rust-ipnet" ,rust-ipnet-2)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-trust-dns-proto" ,rust-trust-dns-proto-0.22)
+                       ("rust-url" ,rust-url-2))))
+    (home-page "https://github.com/bluecatengineering/dhcproto")
+    (synopsis
+     "A DHCP parser and encoder for DHCPv4/DHCPv6")
+    (description
+     "This package provides a DHCP parser and encoder for DHCPv4/DHCPv6.
+@code{dhcproto} aims to be a functionally complete DHCP implementation.")
+    (license license:expat)))
+
 (define-public rust-dhcp4r-0.2
   (package
     (name "rust-dhcp4r")