diff mbox series

[bug#69170,rust-team,46/46] gnu: Add netavark.

Message ID 0749d64a4ce953659d4fe54603aa095da1fcd2a1.1708028703.git.~@wolfsden.cz
State New
Headers show
Series Add netavark | expand

Commit Message

Tomas Volf Feb. 15, 2024, 8:26 p.m. UTC
* gnu/packages/rust-apps.scm (netavark): New variable.

Change-Id: I0febde1f419fe16154e55b7a72dd29554e939fba
---
 gnu/packages/rust-apps.scm | 57 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 93eb4ca68b..71ef962eb3 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2987,3 +2987,60 @@  (define-public htmlq
     (synopsis "Like jq, but for HTML")
     (description "Extract content from HTML files using CSS selectors.")
     (license license:expat)))
+
+(define-public netavark
+  (package
+    (name "netavark")
+    (version "1.10.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "netavark" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1viyj9xqq9hkcsghrfx7wjmky3hkxfr96952f9favd4zg9ih64yw"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+                       ("rust-chrono" ,rust-chrono-0.4)
+                       ("rust-clap" ,rust-clap-4)
+                       ("rust-env-logger" ,rust-env-logger-0.11)
+                       ("rust-fs2" ,rust-fs2-0.4)
+                       ("rust-futures-channel" ,rust-futures-channel-0.3)
+                       ("rust-futures-core" ,rust-futures-core-0.3)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-ipnet" ,rust-ipnet-2)
+                       ("rust-iptables" ,rust-iptables-0.5)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-mozim" ,rust-mozim-0.2)
+                       ("rust-netlink-packet-core" ,rust-netlink-packet-core-0.7)
+                       ("rust-netlink-packet-route" ,rust-netlink-packet-route-0.18)
+                       ("rust-netlink-packet-utils" ,rust-netlink-packet-utils-0.5)
+                       ("rust-netlink-sys" ,rust-netlink-sys-0.8)
+                       ("rust-nftables" ,rust-nftables-0.3)
+                       ("rust-nispor" ,rust-nispor-1)
+                       ("rust-nix" ,rust-nix-0.27)
+                       ("rust-prost" ,rust-prost-0.12)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-value" ,rust-serde-value-0.7)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-sha2" ,rust-sha2-0.10)
+                       ("rust-sysctl" ,rust-sysctl-0.5)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tokio-stream" ,rust-tokio-stream-0.1)
+                       ("rust-tonic" ,rust-tonic-0.10)
+                       ("rust-tonic-build" ,rust-tonic-build-0.10)
+                       ("rust-tower" ,rust-tower-0.4)
+                       ("rust-url" ,rust-url-2)
+                       ("rust-zbus" ,rust-zbus-3))
+       #:cargo-development-inputs (("rust-once-cell" ,rust-once-cell-1)
+                                   ("rust-rand" ,rust-rand-0.8)
+                                   ("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/containers/netavark")
+    (synopsis "A container network stack")
+    (description "Netavark is a rust based network stack for containers.  It
+is being designed to work with Podman but is also applicable for other OCI
+container management applications.")
+    (license license:asl2.0)))