diff mbox series

[bug#69170,rust-team,13/46] gnu: Add rust-prost-derive-0.12.

Message ID e8e2cdcbbb3fea201e187a85dd48d15050e98a82.1708028701.git.~@wolfsden.cz
State New
Headers show
Series Add netavark | expand

Commit Message

Tomas Volf Feb. 15, 2024, 8:26 p.m. UTC
* gnu/packages/crates-io.scm (rust-prost-derive-0.12): New variable.

Change-Id: I730689df44c7d087dda33e7c449b99a502d74517
---
 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1be35e317e..7dd9cc18eb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49508,6 +49508,35 @@  (define-public rust-proptest-derive-0.1
         ("rust-criterion" ,rust-criterion-0.2)
         ("rust-proptest" ,rust-proptest-0.9))))))
 
+(define-public rust-prost-derive-0.12
+  (package
+    (name "rust-prost-derive")
+    (version "0.12.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "prost-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "03l4yf6pdjvc4sgbvln2srq1avzm1ai86zni4hhqxvqxvnhwkdpg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+                       ("rust-itertools" ,rust-itertools-0.10)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2))))
+    (home-page "https://github.com/tokio-rs/prost")
+    (synopsis "Handles generating encoding and decoding implementations for
+types with @code{prost} annotation")
+    (description
+     "@code{prost-derive} handles generating encoding and decoding
+implementations for Rust types annotated with @code{prost} annotation.  For
+the most part, users of @code{prost} shouldn't need to interact with
+@code{prost-derive} directly.")
+    (license license:asl2.0)))
+
 (define-public rust-prost-derive-0.9
   (package
     (name "rust-prost-derive")