diff mbox series

[bug#69170,rust-team,03/46] gnu: Add rust-sync-wrapper-0.1.

Message ID c2c6ddc274a39aff6d5e9e510b21b6c1f00ebca0.1708028701.git.~@wolfsden.cz
State New
Headers show
Series Add netavark | expand

Commit Message

Tomas Volf Feb. 15, 2024, 8:26 p.m. UTC
* gnu/packages/crates-io.scm (rust-sync-wrapper-0.1): New variable.

Change-Id: I2eb340009dfb303130e421ae9f7bbde97e4286fa
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8b2d9a6f78..6250e1f203 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66059,6 +66059,30 @@  (define-public rust-synchronoise-1
 standard library.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-sync-wrapper-0.1
+  (package
+    (name "rust-sync-wrapper")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "sync_wrapper" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0q01lyj0gr9a93n10nxsn8lwbzq97jqd6b768x17c8f7v7gccir0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-futures-core" ,rust-futures-core-0.3))))
+    (home-page "https://docs.rs/sync_wrapper")
+    (synopsis
+     "A tool for enlisting the compiler's help in proving the absence of
+concurrency")
+    (description
+     "This package provides a tool for enlisting the compiler's help in
+proving the absence of concurrency.")
+    (license license:asl2.0)))
+
 (define-public rust-synom-0.11
   (package
     (name "rust-synom")