diff mbox series

[bug#65118,8/9] gnu: Add go-github-com-nsqio-go-nsq.

Message ID f588b20e9989ec063eea5a81f31c6ad5f82580ae.1691350701.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add NSQ. | expand

Commit Message

Sharlatan Hellseher Aug. 6, 2023, 7:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-nsqio-go-nsq): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Maxim Cournoyer Aug. 27, 2023, 2:23 a.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/golang.scm (go-github-com-nsqio-go-nsq): New variable.
> ---
>  gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 637e6ebe73..91b1880476 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -3205,6 +3205,30 @@ (define-public go-github-com-nsqio-go-diskqueue
>       "This package provides a Go package providing a filesystem-backed FIFO queue")
>      (license license:expat)))
>  
> +(define-public go-github-com-nsqio-go-nsq
> +  (package
> +    (name "go-github-com-nsqio-go-nsq")
> +    (version "1.1.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/nsqio/go-nsq")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1h9z3z225sdgg7fl3l7x11xn5ch6lm5flgmcj046cdp453qj2qhf"))))
> +    (build-system go-build-system)
> +    (arguments
> +     (list #:tests? #f ;It requires local network setup.
> +           #:import-path "github.com/nsqio/go-nsq"))
> +    (propagated-inputs (list go-github-com-golang-snappy))
> +    (home-page "https://github.com/nsqio/go-nsq")
> +    (synopsis "Golang package of high-level Consumer and Produce for NSQ")
> +    (description "Package nsq is the official Go package for NSQ
> +(@url{http://nsq.io/,http://nsq.io/}).")

The description should provide more detail than the synopsis, not less
:-).  I'd use something like this, inspired by [0].

--8<---------------cut here---------------start------------->8---
The @code{nsq} Go module provides a high-level consumer and producer
types as well as low-level functions to communicate over the NSQ
protocol.
--8<---------------cut here---------------end--------------->8---

Another thing; when the URL name is the same as the URL itself, you
don't need to repeat it in the @url command.

[0]  https://pkg.go.dev/github.com/nsqio/go-nsq?utm_source=godoc#section-documentation
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 637e6ebe73..91b1880476 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3205,6 +3205,30 @@  (define-public go-github-com-nsqio-go-diskqueue
      "This package provides a Go package providing a filesystem-backed FIFO queue")
     (license license:expat)))
 
+(define-public go-github-com-nsqio-go-nsq
+  (package
+    (name "go-github-com-nsqio-go-nsq")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nsqio/go-nsq")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h9z3z225sdgg7fl3l7x11xn5ch6lm5flgmcj046cdp453qj2qhf"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:tests? #f ;It requires local network setup.
+           #:import-path "github.com/nsqio/go-nsq"))
+    (propagated-inputs (list go-github-com-golang-snappy))
+    (home-page "https://github.com/nsqio/go-nsq")
+    (synopsis "Golang package of high-level Consumer and Produce for NSQ")
+    (description "Package nsq is the official Go package for NSQ
+(@url{http://nsq.io/,http://nsq.io/}).")
+    (license license:expat)))
+
 (define-public go-github-com-hebcal-gematriya
   (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
         (revision "0"))