diff mbox series

[bug#65118,3/9] gnu: Add go-github-com-bmizerany-perks-quantile.

Message ID dd35850030451700572b8a72655397383867975a.1691350701.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add NSQ. | expand

Commit Message

Sharlatan Hellseher Aug. 6, 2023, 7:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-bmizerany-perks-quantile): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Maxim Cournoyer Aug. 27, 2023, 2:10 a.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/golang.scm (go-github-com-bmizerany-perks-quantile): New variable.
> ---
>  gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 4721519a9b..ce46e02158 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -9033,6 +9033,30 @@ (define-public go-github-com-bmatcuk-doublestar
>  matching and globbing with support for \"doublestar\" patterns.")
>      (license license:expat)))
>  
> +(define-public go-github-com-bmizerany-perks-quantile
> +  (package
> +    (name "go-github-com-bmizerany-perks-quantile")
> +    (version "0.0.0-20230307044200-03f9df79da1e")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/bmizerany/perks")
> +                    (commit (go-version->git-ref version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1f2a99v3618bz2mf61iwhdjm3xi1gam6v4apqgcrz71gj7ba9943"))))
> +    (build-system go-build-system)
> +    (arguments
> +     (list #:unpack-path "github.com/bmizerany/perks"
> +           #:import-path "github.com/bmizerany/perks/quantile"))
> +    (home-page "https://github.com/bmizerany/perks")
> +    (synopsis "Perks for Golang")

I'd use "Library for computing quantiles"

> +    (description
> +     "Perks contains the Go package quantile that computes approximate quantiles

the Go package @code{quantile} [...]
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4721519a9b..ce46e02158 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9033,6 +9033,30 @@  (define-public go-github-com-bmatcuk-doublestar
 matching and globbing with support for \"doublestar\" patterns.")
     (license license:expat)))
 
+(define-public go-github-com-bmizerany-perks-quantile
+  (package
+    (name "go-github-com-bmizerany-perks-quantile")
+    (version "0.0.0-20230307044200-03f9df79da1e")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bmizerany/perks")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1f2a99v3618bz2mf61iwhdjm3xi1gam6v4apqgcrz71gj7ba9943"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:unpack-path "github.com/bmizerany/perks"
+           #:import-path "github.com/bmizerany/perks/quantile"))
+    (home-page "https://github.com/bmizerany/perks")
+    (synopsis "Perks for Golang")
+    (description
+     "Perks contains the Go package quantile that computes approximate quantiles
+over an unbounded data stream within low memory and CPU bounds.")
+    (license license:bsd-2)))
+
 (define-public go-github-com-dlclark-regexp2
   (package
     (name "go-github-com-dlclark-regexp2")