diff mbox series

[bug#65118,6/9] gnu: Add go-github-com-mreiferson-go-options.

Message ID 8e3228708dc30a784f2c217144ed01208b9d9cf3.1691350701.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add NSQ. | expand

Commit Message

Sharlatan Hellseher Aug. 6, 2023, 7:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mreiferson-go-options): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Maxim Cournoyer Aug. 27, 2023, 2:15 a.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/golang.scm (go-github-com-mreiferson-go-options): New variable.
> ---
>  gnu/packages/golang.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index cdfad943c7..fd3807bb7e 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -6256,6 +6256,29 @@ (define-public go-github-com-mr-tron-base58
>  encoding and 8 times faster decoding.")
>        (license license:expat))))
>  
> +(define-public go-github-com-mreiferson-go-options
> +  (package
> +    (name "go-github-com-mreiferson-go-options")
> +    (version "1.0.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/mreiferson/go-options")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1pxs9ybrh196qy14ijn4zn51h2z28lj31y6vxrz2xxhgvpmfmxyl"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/mreiferson/go-options"))
> +    (home-page "https://github.com/mreiferson/go-options")
> +    (synopsis "Go package to structure and resolve options")
> +    (description
> +     "OPTIONS resolves configuration values set via command line
> flags, config

Maybe, "The @code{options} Go package resolves [...]"
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cdfad943c7..fd3807bb7e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6256,6 +6256,29 @@  (define-public go-github-com-mr-tron-base58
 encoding and 8 times faster decoding.")
       (license license:expat))))
 
+(define-public go-github-com-mreiferson-go-options
+  (package
+    (name "go-github-com-mreiferson-go-options")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mreiferson/go-options")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pxs9ybrh196qy14ijn4zn51h2z28lj31y6vxrz2xxhgvpmfmxyl"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/mreiferson/go-options"))
+    (home-page "https://github.com/mreiferson/go-options")
+    (synopsis "Go package to structure and resolve options")
+    (description
+     "OPTIONS resolves configuration values set via command line flags, config
+files, and default struct values")
+    (license license:expat)))
+
 (define-public go-github-com-mreiferson-go-svc
   ;; NSQ specific fork of github.com/judwhite/go-svc, as Guix go build system
   ;; does not support go.mod with `replace' statement.