diff mbox series

[bug#65118,2/9] gnu: Add go-github-com-bitly-timer-metrics.

Message ID 1128f68bf020ede3f1b960d25d80e0ac0bb5fd8c.1691350701.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add NSQ. | expand

Commit Message

Sharlatan Hellseher Aug. 6, 2023, 7:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-bitly-timer-metrics): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Maxim Cournoyer Aug. 27, 2023, 2:08 a.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/golang.scm (go-github-com-bitly-timer-metrics): New variable.
> ---
>  gnu/packages/golang.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 0a747f2eee..4721519a9b 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -2137,6 +2137,29 @@ (define-public go-github-com-bitly-go-hostpool
>  robin or epsilon greedy mode, and unresponsive hosts are avoided.")
>      (license license:expat)))
>  
> +(define-public go-github-com-bitly-timer-metrics
> +  (package
> +    (name "go-github-com-bitly-timer-metrics")
> +    (version "1.0.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/bitly/timer_metrics")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "02fhx8hx8126m2cgxw9fm8q2401r7zfann8b5zy5yyark1sgkrb4"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/bitly/timer_metrics"))
> +    (home-page "https://github.com/bitly/timer_metrics")
> +    (synopsis "Capture timings and enables periodic metrics every n
> events")

s/enables/enable/

Maybe use @var{n} if that's supported.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0a747f2eee..4721519a9b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2137,6 +2137,29 @@  (define-public go-github-com-bitly-go-hostpool
 robin or epsilon greedy mode, and unresponsive hosts are avoided.")
     (license license:expat)))
 
+(define-public go-github-com-bitly-timer-metrics
+  (package
+    (name "go-github-com-bitly-timer-metrics")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bitly/timer_metrics")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "02fhx8hx8126m2cgxw9fm8q2401r7zfann8b5zy5yyark1sgkrb4"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/bitly/timer_metrics"))
+    (home-page "https://github.com/bitly/timer_metrics")
+    (synopsis "Capture timings and enables periodic metrics every n events")
+    (description
+     "This package provides an efficient way to capture timing information and
+periodically output metrics")
+    (license license:expat)))
+
 (define-public go-github-com-blanu-dust
   (package
     (name "go-github-com-blanu-dust")