diff mbox series

[bug#68813,core-updates,20/20] Revert "gnu: mpv: Propagate most libraries."

Message ID f3af34287b41cecf06819630151dbe7673f0986e.1708618218.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Replace pkg-config with pkgconf to reduce propagation / Inkscape updates | expand

Commit Message

Maxim Cournoyer Feb. 22, 2024, 4:10 p.m. UTC
This reverts commit f3fdb4e041cb5740ba0b38b9ad017571f8414d33.  This is made
possible by having replaced pkg-config with pkgconf, which more strictly
interprets the private fields as purely for static compilation.

Change-Id: I1c06623a4501bbcddfb80aa3cfd79a08409a08ae
---

 gnu/packages/video.scm | 33 +++++++++++++--------------------
 1 file changed, 13 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c70646eccd..0746413ed8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2641,43 +2641,31 @@  (define-public mpv
               "-Ddvdnav=enabled"
               "-Dbuild-date=false")))
     (native-inputs
-     (list perl                         ;for zsh completion file
-           pkg-config
-           python-docutils
-           python-wrapper))
+     (list perl ; for zsh completion file
+           pkg-config python-docutils python-wrapper))
     ;; Missing features: libguess, V4L2.
     (inputs
-     (list enca
-           ladspa
-           lcms
-           libbs2b
-           mpg123
-           rsound
-           vulkan-headers
-           vulkan-loader
-           yt-dlp))
-    ;; XXX: These are propagated for the mpv pkg-config package, as they are
-    ;; listed in Requires.private and would break 'pkg-config --exists mpv' if
-    ;; unavailable.
-    (propagated-inputs
      (list alsa-lib
+           enca
            ffmpeg
            jack-1
+           ladspa
+           lcms
            libass
            libbluray
            libcaca
+           libbs2b
            libcdio-paranoia
-           libdrm
-           libdvdnav
            libdvdread
+           libdvdnav
            libjpeg-turbo
            libplacebo
            libva
            libvdpau
            libx11
            libxext
-           libxinerama
            libxkbcommon
+           libxinerama
            libxpresent
            libxrandr
            libxscrnsaver
@@ -2685,10 +2673,15 @@  (define-public mpv
            ;; XXX: lua > 5.2 is not currently supported; see meson.build
            lua-5.2
            mesa
+           mpg123
            pulseaudio
+           rsound
            shaderc
+           vulkan-headers
+           vulkan-loader
            wayland
            wayland-protocols
+           yt-dlp
            zimg
            zlib))
     (home-page "https://mpv.io/")