diff mbox series

[bug#68813,core-updates,18/20] gnu: inkscape: Sort inputs.

Message ID c64f4aa58c7b6fd385f0ab3c01fee2db0343d08a.1708618218.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Replace pkg-config with pkgconf to reduce propagation / Inkscape updates | expand

Commit Message

Maxim Cournoyer Feb. 22, 2024, 4:10 p.m. UTC
* gnu/packages/inkscape.scm (inkscape/stable) [inputs]: Sort.
[native-inputs]: Likewise.

Change-Id: I64253e52bf157013e6c55361f7633cbd01dcb020
---

 gnu/packages/inkscape.scm | 38 +++++++++++++++++++-------------------
 1 file changed, 19 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 1e674add9e..5449bf8d92 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -254,43 +254,43 @@  (define-public inkscape/stable
                  `("GDK_PIXBUF_MODULE_FILE" =
                    (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))
      (inputs
-      (list autotrace
+      (list (librsvg-for-system)        ;for the pixbuf loader
+            autotrace
             bash-minimal
+            boost
+            freetype
             gdl-minimal
-            gtkmm-3
-            gtk+
             gsl
             gspell
-            poppler
+            gtk+
+            gtkmm-3
+            lcms
             lib2geom
+            libcdr
+            libgc
             libjpeg-turbo
             libpng
-            libxml2
-            libxslt
-            libgc
-            (librsvg-for-system)        ;for the pixbuf loader
             libsoup-minimal-2
-            libcdr
             libvisio
             libwpd
             libwpg
-            freetype
+            libxml2
+            libxslt
+            poppler
             popt
             potrace
-            lcms
-            boost
-            python-wrapper
-            python-scour
-            python-pyserial
-            python-numpy
             python-lxml
+            python-numpy
+            python-pyserial
+            python-scour
+            python-wrapper
             readline))
      (native-inputs
-      (list bc
+      (list `(,glib "bin")
+            bc
             gettext-minimal
-            imagemagick/stable          ;for tests
-            `(,glib "bin")
             googletest
+            imagemagick/stable          ;for tests
             perl
             pkg-config))
      (home-page "https://inkscape.org/")