mbox series

[bug#68813,core-updates,00/20] Replace pkg-config with pkgconf to reduce propagation / Inkscape updates

Message ID cover.1708618218.git.maxim.cournoyer@gmail.com
Headers show
Series Replace pkg-config with pkgconf to reduce propagation / Inkscape updates | expand

Message

Maxim Cournoyer Feb. 22, 2024, 4:09 p.m. UTC
As demonstrated in this series, pkgconf's improved behavior for private fields
mean we do not need to propagate them in the usual case (shared linking),
which in turn means we can reduce the number of propagated inputs.

This series also explores removing libtool archives (.la) files, as these also
introduce the need to propagate libraries.  Moreover, they cause overlinking
in the context of ELF shared libraries.  A future series could explore moving
these to the "static" output, when it exists, along .a file and pkg-config
files.

Maxim Cournoyer (20):
  gnu: Add atf.
  gnu: Add lutok.
  gnu: Add kyua.
  gnu: pkgconf: Enable test suite.
  gnu: Add pkgconf-as-pkg-config.
  gnu: pkgconf: Add $PKG_CONFIG_PATH search path.
  gnu: pkgconf: Add support for cross-compilation.
  gnu: pkg-config: Alias to pkgconf-as-pkg-config.
  gnu: pstoedit: Update to 4.00.
  gnu: autotrace: Update to 0.31.10.
  gnu: autotrace: Remove libtool archives.
  gnu: autotrace: Fix pkg-config file.
  gnu: gd: Update to 2.3.3.
  gnu: lib2geom: Update to 1.3.
  gnu: inkscape: Truly enable ImageMagic support.
  gnu: lib2geom: Use gexps and remove input labels.
  gnu: inkscape: Update to 1.3.2.
  gnu: inkscape: Sort inputs.
  gnu: inkscape: Fix Python support.
  Revert "gnu: mpv: Propagate most libraries."

 gnu/local.mk                                  |   7 +-
 gnu/packages/check.scm                        | 110 ++++++-
 gnu/packages/commencement.scm                 |  13 +-
 gnu/packages/gd.scm                           |  57 ++--
 gnu/packages/graphics.scm                     | 132 +++++----
 gnu/packages/inkscape.scm                     | 149 ++++++----
 gnu/packages/lua.scm                          |  41 +++
 .../patches/atf-execute-with-shell.patch      |  39 +++
 .../patches/autotrace-pkg-config.patch        | 123 ++++++++
 .../patches/gd-Revert-fix-303-gdlib.pc.patch  | 179 ------------
 .../patches/inkscape-poppler-compat.patch     |  45 ---
 gnu/packages/patches/pstoedit-fix-gcc12.patch |  12 +
 .../patches/pstoedit-fix-plainC.patch         |  47 +++
 gnu/packages/patches/pstoedit-pkglibdir.patch |  19 ++
 gnu/packages/pkg-config.scm                   | 271 ++++++++++++------
 gnu/packages/video.scm                        |  33 +--
 16 files changed, 791 insertions(+), 486 deletions(-)
 create mode 100644 gnu/packages/patches/atf-execute-with-shell.patch
 create mode 100644 gnu/packages/patches/autotrace-pkg-config.patch
 delete mode 100644 gnu/packages/patches/gd-Revert-fix-303-gdlib.pc.patch
 delete mode 100644 gnu/packages/patches/inkscape-poppler-compat.patch
 create mode 100644 gnu/packages/patches/pstoedit-fix-gcc12.patch
 create mode 100644 gnu/packages/patches/pstoedit-fix-plainC.patch
 create mode 100644 gnu/packages/patches/pstoedit-pkglibdir.patch


base-commit: a0fd71f7b44ea9ef0eed7417cff604b3ada4032d