diff mbox series

[bug#62579,3/3] gnu: Add r-tarchetypes

Message ID f03956aebaedf052f7d43f3ab4cc8a4ad246914a.1680324055.git.kyle@posteo.net
State New
Headers show
Series *** Package targets and tarchetypes *** | expand

Commit Message

kyle April 1, 2023, 4:57 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d2036b0629..56dcf705db 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14456,6 +14456,43 @@  (define-public r-tab
 handle data from simple random samples as well as complex surveys.")
     (license license:gpl3+)))
 
+
+(define-public r-tarchetypes
+  (package
+    (name "r-tarchetypes")
+    (version "0.7.5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "tarchetypes" version))
+              (sha256
+               (base32
+		"05yhq8xnrpk37x7fq0yjw4m527ji28s16dskfmljrbrzb064nw2g"))))
+    (properties `((upstream-name . "tarchetypes")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-digest
+                             r-dplyr
+                             r-fs
+                             r-furrr
+                             r-future
+                             r-future-callr
+                             r-rlang
+                             r-targets
+                             r-tibble
+                             r-tidyselect
+                             r-vctrs
+                             r-withr))
+    (home-page "https://docs.ropensci.org/tarchetypes/")
+    (synopsis "Archetypes for Targets")
+    (description
+     "Function-oriented Make-like declarative pipelines for Statistics and data
+science are supported in the targets R package.  As an extension to targets',
+the tarchetypes package provides convenient user-side functions to make targets
+easier to use.  By establishing reusable archetypes for common kinds of targets
+and pipelines, these functions help express complicated reproducible pipelines
+concisely and compactly.  The methods in this package were influenced by the
+drake R package by Will Landau (2018) <doi:10.21105/joss.00550>.")
+    (license license:expat)))
+
 (define-public r-targets
   (package
     (name "r-targets")