diff mbox series

[bug#62579,1/3] gnu: Add r-targets package

Message ID 5ae044eb9f0e7fd794a0368b736a66d77a7094d9.1680324055.git.kyle@posteo.net
State New
Headers show
Series *** Package targets and tarchetypes *** | expand

Commit Message

kyle April 1, 2023, 4:57 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Ricardo Wurmus April 4, 2023, 5:46 p.m. UTC | #1
Hi Kyle,

thank you for the patches!  I applied them with the commits ending with
4d313b918ec6d2ed05dd16030a860c162e63d8a0.

I slightly adjusted descriptions and indentation (each of the patches
had tabs on the hash line) and added r-markdown where the vignette
builder needed it.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f2bdd750ca..3e8ec429e1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14456,6 +14456,47 @@  (define-public r-tab
 handle data from simple random samples as well as complex surveys.")
     (license license:gpl3+)))
 
+(define-public r-targets
+  (package
+    (name "r-targets")
+    (version "0.14.3")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "targets" version))
+              (sha256
+               (base32
+		"0mhwvlbxnb4w054pjiw2smss28i90sg52w8v040y7sqy6gq2c8n6"))))
+    (properties `((upstream-name . "targets")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-base64url
+                             r-callr
+                             r-cli
+                             r-codetools
+                             r-data-table
+                             r-digest
+                             r-igraph
+                             r-knitr
+                             r-r6
+                             r-rlang
+                             r-tibble
+                             r-tidyselect
+                             r-vctrs
+                             r-withr
+                             r-yaml))
+    (native-inputs (list r-knitr))
+    (home-page "https://docs.ropensci.org/targets/")
+    (synopsis "Dynamic Function-Oriented 'Make'-Like Declarative Pipelines")
+    (description
+     "This package provides a pipeline toolkit for Statistics and data science in R,
+the targets package brings function-oriented programming to Make'-like
+declarative pipelines.  targets orchestrates a pipeline as a graph of
+dependencies, skips steps that are already up to date, runs the necessary
+computation with optional parallel workers, abstracts files as R objects, and
+provides tangible evidence that the results are reproducible given the
+underlying code and data.  The methodology in this package borrows from GNU Make
+(2015, ISBN:978-9881443519) and drake (2018, <doi:10.21105/joss.00550>).")
+    (license license:expat)))
+
 (define-public r-dvmisc
   (package
     (name "r-dvmisc")