diff mbox series

[bug#62579,2/3] gnu: Add r-future-callr

Message ID 1493a333b0fb7ac47df2c273a47f3d77195145dc.1680324055.git.kyle@posteo.net
State New
Headers show
Series *** Package targets and tarchetypes *** | expand

Commit Message

kyle April 1, 2023, 4:57 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3e8ec429e1..d2036b0629 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19309,6 +19309,37 @@  (define-public r-future-apply
 machine or distributed on a compute cluster.")
     (license license:gpl2+)))
 
+(define-public r-future-callr
+  (package
+    (name "r-future-callr")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "future.callr" version))
+              (sha256
+               (base32
+		"1w7wq2nrvj65a25nsb5h99258p9565qwnlvcc07nyc21gm5zrg9k"))))
+    (properties `((upstream-name . "future.callr")))
+    (build-system r-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-HOME
+            (lambda _ (setenv "HOME" "/tmp"))))))
+    (propagated-inputs (list r-callr r-future))
+    (native-inputs (list r-r-rsp))
+    (home-page "https://future.callr.futureverse.org")
+    (synopsis "Future API for Parallel Processing using 'callr'")
+    (description
+     "Implementation of the Future API on top of the callr package.  This allows you
+to process futures, as defined by the future package, in parallel out of the
+box, on your local (Linux, macOS, Windows, ...) machine.  Contrary to backends
+relying on the parallel package (e.g. future::multisession') and socket
+connections, the callr backend provided here can run more than 125 parallel R
+processes.")
+    (license license:lgpl2.1+)))
+
 (define-public r-rsvd
   (package
     (name "r-rsvd")