diff mbox series

[bug#68990,14/28] gnu: Add ruby-serverspec.

Message ID ee0123db5679a939f3efebdb0d2376b8951820c3.1707383695.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Some ruby packages | expand

Commit Message

Hartmut Goebel Feb. 8, 2024, 9:35 a.m. UTC
* gnu/packages/ruby.scm (ruby-serverspec): New variable.
---
 gnu/packages/ruby.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 417ae9b277..4299673313 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1240,6 +1240,36 @@  (define-public ruby-specinfra
     (home-page "https://github.com/mizzy/specinfra")
     (license license:expat)))
 
+(define-public ruby-serverspec
+  (package
+    (name "ruby-serverspec")
+    (version "2.42.3")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "serverspec" version))
+              (sha256
+               (base32
+                "0kfaqrqynly8n3dy5qrbjvx4lx6mk9a5vynwb7xwqj8bixm0mab4"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-multi-json ruby-rspec ruby-rspec-its
+                             ruby-specinfra))
+    (arguments
+     (list #:test-target "spec"))
+    (synopsis
+     "RSpec tests for servers configured by Puppet, Chef, Itamae, etc")
+    (description
+     "With Serverspec, you can write RSpec tests for checking your servers are
+configured correctly.
+
+Serverspec tests your servers’ actual state by executing command locally, via
+SSH, via WinRM, via Docker API and so on.  So you don’t need to install any
+agent softwares on your servers and can use any configuration management
+tools, Puppet, Ansible, CFEngine, Itamae and so on.
+
+But the true aim of Serverspec is to help refactoring infrastructure code.")
+    (home-page "https://serverspec.org/")
+    (license license:expat)))
+
 ;; Bundler is yet another source of circular dependencies, so we must disable
 ;; its test suite as well.
 (define-public bundler