diff mbox series

[bug#68990,05/28] gnu: Add ruby-fake-ftp.

Message ID a4acac192eef512e6fe4448a418af51fb5f73b7b.1707383694.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Some ruby packages | expand

Commit Message

Hartmut Goebel Feb. 8, 2024, 9:35 a.m. UTC
* gnu/packages/ruby.scm (ruby-fake-ftp): New variable.
---
 gnu/packages/ruby.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 16dcfc4173..d9df2881cf 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4448,6 +4448,27 @@  (define-public ruby-ipaddr
     (home-page "https://github.com/ruby/ipaddr")
     (license license:bsd-2)))
 
+(define-public ruby-fake-ftp
+  (package
+    (name "ruby-fake-ftp")
+    (version "0.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "fake_ftp" version))
+              (sha256
+               (base32
+                "1zl9q9m4x7lz9890g0h1qqj7hcxnwzpjfnfbxadjblps7b5054q4"))))
+    (build-system ruby-build-system)
+    (native-inputs (list ruby-rspec ruby-rubocop ruby-simplecov))
+    (arguments
+     '(#:test-target "spec"))
+    (synopsis "Fake FTP server for use with ruby tests")
+    (description "This package allows you to test FTP implementations in ruby.
+It is a minimal single-client FTP server that can be bound to any arbitrary
+port on localhost.")
+    (home-page "https://rubygems.org/gems/fake_ftp")
+    (license license:expat)))
+
 (define-public ruby-net-ftp
   (package
     (name "ruby-net-ftp")