diff mbox series

[bug#68990,18/28] gnu: Add ruby-grpc.

Message ID 89a78fc3abc71be8be1a348e46993499ad9b2da6.1707383695.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Some ruby packages | expand

Commit Message

Hartmut Goebel Feb. 8, 2024, 9:35 a.m. UTC
* gnu/packages/ruby.scm (ruby-grpc): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 67d9733764..78cb0fa064 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -17782,6 +17782,29 @@  (define-public ruby-googleapis-common-protos-types
     (home-page "https://github.com/googleapis/common-protos-ruby")
     (license license:asl2.0)))
 
+(define-public ruby-grpc
+  (package
+    (name "ruby-grpc")
+    (version "1.61.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "grpc" version))
+              (sha256
+               (base32
+                "09ifqn0y33bm7rhnwry9b7kgijh2hbl57bp70vg1md8ga9k283kc"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f))  ;; has no tests
+    ;; TODO remove third-party sources (zlib, upb, utf8-range, re2, c-ares,
+    ;; boringssl-with-bazel, address_sorting, abseil-cpp), see Makefile
+    (propagated-inputs (list ruby-googleapis-common-protos-types
+                             ruby-google-protobuf))
+    (synopsis "GRPC system in Ruby")
+    (description "GRPC is a high performance, open-source universal RPC
+framework.  This package provides a ruby interface for it.")
+    (home-page "https://github.com/grpc/grpc/tree/master/src/ruby")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar