diff mbox series

[bug#68990,04/28] gnu: Add ruby-net-ftp.

Message ID 17ab17da4446b0c9fc9f5f043960ded34eae59fd.1707383694.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Some ruby packages | expand

Commit Message

Hartmut Goebel Feb. 8, 2024, 9:35 a.m. UTC
* gnu/packages/ruby.scm (ruby-net-ftp): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f3b34cb154..16dcfc4173 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4448,6 +4448,29 @@  (define-public ruby-ipaddr
     (home-page "https://github.com/ruby/ipaddr")
     (license license:bsd-2)))
 
+(define-public ruby-net-ftp
+  (package
+    (name "ruby-net-ftp")
+    (version "0.3.4")
+    (source (origin
+              (method git-fetch)  ;for tests
+              (uri (git-reference
+                    (url "https://github.com/ruby/net-ftp")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "11b1sw7c4c7xrhn5li5m0wylw42hp52jp6pqacyb43hkw1m5zr36"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-net-protocol ruby-time))
+    (synopsis "File Transfer Protocol client library")
+    (description "This class implements the File Transfer Protocol.  If you
+have used a command-line FTP program, and are familiar with the commands, you
+will be able to use this class easily.  Some extra features are included to
+take advantage of Ruby's style and strengths.")
+    (home-page "https://github.com/ruby/net-ftp")
+    (license license:bsd-2)))
+
 (define-public ruby-net-http-persistent
   (package
     (name "ruby-net-http-persistent")