diff mbox series

[bug#42682,v3,5/9] gnu: Add python-milc.

Message ID e6b68a97a02653b11bce8167c5b73698c90ba13c.1685316748.git.plattfot@posteo.net
State New
Headers show
Series Add qmk-cli | expand

Commit Message

Fredrik Salomonsson May 28, 2023, 11:44 p.m. UTC
* gnu/packages/python-xyz.scm (python-milc): New variable.
---
 gnu/packages/python-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5df4e30e83..9b71ba1872 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17685,6 +17685,51 @@  (define-public python-magic
 the same purpose: to provide Python bindings for libmagic.")
     (license license:expat)))
 
+(define-public python-milc
+  (package
+    (name "python-milc")
+    (version "1.6.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "milc" version))
+              (sha256
+               (base32
+                "007hdwp659s1wfld92pxdgjz9ijvh949wyf1cbmyzkma30vng8d4"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list
+      python-appdirs
+      python-argcomplete
+      python-colorama
+      python-halo
+      python-spinners))
+    (home-page "https://milc.clueboard.co/")
+    (synopsis "Opinionated Batteries-Included Python 3 CLI Framework")
+    (description "MILC is a framework for writing @acronym{CLI, Command Line Interface}
+applications in Python 3.6+.  It gives you all the features users
+expect from a modern CLI tool out of the box:
+@itemize @bullet
+@item
+CLI Argument Parsing, with or without subcommands.
+@item
+Automatic tab-completion support through argcomplete.
+@item
+Configuration file which can be overridden by CLI options.
+@item
+ANSI color support- even on Windows- with colorama.
+@item
+Logging to stderr and/or a file, with ANSI colors.
+@item
+Easy method for printing to stdout with ANSI colors
+@item
+Labeling log output with colored emoji to easily distinguish message types.
+@item
+Thread safety.
+@item
+More than 60 built-in spinners with the ability to add your own.
+@end itemize")
+    (license license:expat)))
+
 (define-public s3cmd
   (package
     (name "s3cmd")