diff mbox series

[bug#42682,v3,6/9] gnu: Add python-dotty-dict.

Message ID 329d49c7d235ed6e3130ff6b251dffa7ee91779c.1685316748.git.plattfot@posteo.net
State New
Headers show
Series Add qmk-cli | expand

Commit Message

Fredrik Salomonsson May 28, 2023, 11:44 p.m. UTC
* gnu/packages/python-xyz.scm (python-dotty-dict): New variable.
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b71ba1872..947e33176c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28145,6 +28145,42 @@  (define-public python-dictpath
 accessor layer.")
     (license license:asl2.0)))
 
+(define-public python-dotty-dict
+  (package
+    (name "python-dotty-dict")
+    (version "1.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "dotty_dict" version))
+              (sha256
+               (base32
+                "058sah2nyg44xq5wxywlzc3abzcv9fifnlvsflwma9mfp01nw0ab"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/pawelzny/dotty_dict")
+    (synopsis "Dictionary wrapper for quick access to deeply nested keys")
+    (description "Has the following features:
+@itemize @bullet
+@item
+Simple wrapper around python dictionary and dict like objects.
+@item
+Two wrappers with the same dict are considered equal.
+@item
+Access to deeply nested keys with dot notation: @code{dot['deeply.nested.key']}.
+@item
+Create, read, update and delete nested keys of any length.
+@item
+Expose all dictionary methods like @code{.get}, @code{.pop}, @code{.keys} and other.
+@item
+Access dicts in lists by index @code{dot['parents.0.first_name']}.
+@item
+key=value caching to speed up lookups and low down memory consumption.
+@item
+Support for setting value in multidimensional lists.
+@item
+Support for accessing lists with slices.
+@end itemize")
+    (license license:expat)))
+
 (define-public pyzo
   (package
     (name "pyzo")