diff mbox series

[bug#42682,v3,1/9] gnu: Add python-hjson.

Message ID 35e65b5e4fd47ee0756cfaab537ed9b1e9b52031.1685316748.git.plattfot@posteo.net
State New
Headers show
Series Add qmk-cli | expand

Commit Message

Fredrik Salomonsson May 28, 2023, 11:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-hjson): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7e3f6f538..e6fc35eb6c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -137,6 +137,7 @@ 
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Fredrik Salomonsson <plattfot@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2594,6 +2595,25 @@  (define-public python-humanfriendly
 helpers.")
     (license license:expat)))
 
+(define-public python-hjson
+  (package
+    (name "python-hjson")
+    (version "3.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "hjson" version))
+              (sha256
+               (base32
+                "0xfgrnwr6xaqfkaxnzd06sw8zv6dpkbrk0w0kjbag0yg4xd4gbsm"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f)) ; no tests
+    (home-page "https://github.com/hjson/hjson-py")
+    (synopsis "Hjson, the Human JSON user interface")
+    (description "This package provides a configuration file format that caters
+to humans and helps reduce the errors they make.")
+    (license license:expat)))
+
 (define-public python-textparser
   (package
     (name "python-textparser")