[bug#42682,v3,4/9] gnu: Add python-halo.
Commit Message
* gnu/packages/python-xyz.scm (python-halo): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -16086,6 +16086,37 @@ (define-public python-log-symbols
(description "This package provides a Python module that generates colored symbols
for info, success, warning and error log level.")
(license license:expat)))
+
+(define-public python-halo
+ (package
+ (name "python-halo")
+ (version "0.0.31")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "halo" version))
+ (sha256
+ (base32
+ "1mn97h370ggbc9vi6x8r6akd5q8i512y6kid2nvm67g93r9a6rvv"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-tox
+ python-nose
+ python-coverage
+ python-pylint
+ python-twine))
+ (propagated-inputs
+ (list python-colorama
+ python-log-symbols
+ python-six
+ python-spinners
+ python-termcolor))
+ (home-page "https://github.com/manrajgrover/halo")
+ (synopsis "Beautiful terminal spinners in Python")
+ (description "This package provides a Python module that renders various
+fancy looking terminal spinners. The API allow to control color on text
+and/or spinner, what animation if text does not fit etc.")
+ (license license:expat)))
+
(define-public python-moto
(package
(name "python-moto")