diff mbox series

[bug#69048,20/32] gnu: Add rust-speedate-0.13.

Message ID e428afa428a6cd38e58f344f28015f3cbb9893d4.1707650794.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add python-pydantic v2 and required rust and python packages | expand

Commit Message

Hartmut Goebel Feb. 11, 2024, 11:43 a.m. UTC
* gnu/packages/crates-io.scm (rust-speedate-0.13): New variable.
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3f26aef89d..26678f8bfd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -72867,6 +72867,30 @@  (define-public rust-speculate-0.1
      "An RSpec inspired minimal testing framework for Rust.")
     (license license:expat)))
 
+(define-public rust-speedate-0.13
+  (package
+    (name "rust-speedate")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "speedate" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "16xi4d98ab3ag7rkba2fv37kk3d0fgg0l287hq4vz36i1z2pcbr4"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-strum" ,rust-strum-0.25)
+                       ("rust-strum-macros" ,rust-strum-macros-0.25))
+       #:cargo-development-inputs (("rust-chrono" ,rust-chrono-0.4)
+                                   ("rust-iso8601" ,rust-iso8601-0.4)
+                                   ("rust-paste" ,rust-paste-1))))
+    (home-page "https://github.com/pydantic/speedate/")
+    (synopsis "Fast and simple datetime, date, time and duration parsing")
+    (description "@code{speedate} is a lax RFC 3339 date and time parser, in
+other words, it parses common ISO 8601 formats.")
+    (license license:expat)))
+
 (define-public rust-speedy-0.8
   (package
     (name "rust-speedy")