diff mbox series

[bug#69048,21/32] gnu: Add rust-zerocopy-derive-0.7.

Message ID c137749c02c5283b442347522ab4998b747d2fa8.1707650794.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add python-pydantic v2 and required rust and python packages | expand

Commit Message

Hartmut Goebel Feb. 11, 2024, 11:43 a.m. UTC
* gnu/packages/crates-io.scm (rust-zerocopy-derive-0.7): New variable.
  (rust-zerocopy-derive-0.3): Inherit from rust-zerocopy-derive-0.7.
---
 gnu/packages/crates-io.scm | 38 ++++++++++++++++++++++++++++++--------
 1 file changed, 30 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 26678f8bfd..3100aae670 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -91401,8 +91401,37 @@  (define-public rust-zerocopy-0.3
         ("rust-zerocopy-derive" ,rust-zerocopy-derive-0.2))))
     (license license:bsd-3)))
 
+(define-public rust-zerocopy-derive-0.7
+  (package
+    (name "rust-zerocopy-derive")
+    (version "0.7.32")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "zerocopy-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "19nj11md42aijyqnfx8pa647fjzhz537xyc624rajwwfrn6b3qcw"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-2))
+       #:cargo-development-inputs
+       (("rust-static-assertions" ,rust-static-assertions-1)
+        ("rust-trybuild" ,rust-trybuild-1))))
+    (home-page "https://github.com/google/zerocopy")
+    (synopsis "Custom derive for traits from the zerocopy Rust crate")
+    (description
+     "This package provides custom derive for traits from the zerocopy Rust
+crate.")
+    (license license:bsd-2)))
+
 (define-public rust-zerocopy-derive-0.3
   (package
+    (inherit rust-zerocopy-derive-0.7)
     (name "rust-zerocopy-derive")
     (version "0.3.2")
     (source (origin
@@ -91412,19 +91441,12 @@  (define-public rust-zerocopy-derive-0.3
               (sha256
                (base32
                 "18qr7dqlj89v1xl1g58l2xd6jidv0sbccscgl131gpppba0yc1b5"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-proc-macro2" ,rust-proc-macro2-1)
         ("rust-syn" ,rust-syn-1)
-        ("rust-synstructure" ,rust-synstructure-0.12))))
-    (home-page "https://github.com/google/zerocopy")
-    (synopsis "Custom derive for traits from the zerocopy Rust crate")
-    (description
-     "This package provides custom derive for traits from the zerocopy Rust
-crate.")
-    (license license:bsd-2)))
+        ("rust-synstructure" ,rust-synstructure-0.12))))))
 
 (define-public rust-zerocopy-derive-0.2
   (package