diff mbox series

[bug#69048,27/32] gnu: Add rust-pyo3-0.20.

Message ID d1090c61956822cffeeb30b6a160ef4018237295.1707650794.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add python-pydantic v2 and required rust and python packages | expand

Commit Message

Hartmut Goebel Feb. 11, 2024, 11:43 a.m. UTC
* gnu/packages/crates-io.scm (rust-pyo3-0.20): New variable.
  (rust-pyo3-0.19): Inherit from rust-pyo3-0.20.
---
 gnu/packages/crates-io.scm | 65 ++++++++++++++++++++++++++++++++------
 1 file changed, 56 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fe22a6603a..3701b3f310 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -59152,8 +59152,63 @@  (define-public rust-pyo3-macros-0.15
         ("rust-syn" ,rust-syn-1))))
     (native-inputs (list python))))
 
+(define-public rust-pyo3-0.20
+  (package
+    (name "rust-pyo3")
+    (version "0.20.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "pyo3" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1q3g7ppg2qskigbgqg3w9280klkil5is9hhyps1ykl2hb1xdr2cs"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-anyhow" ,rust-anyhow-1)
+        ("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-either" ,rust-either-1)
+        ("rust-eyre" ,rust-eyre-0.6)
+        ("rust-hashbrown" ,rust-hashbrown-0.14)
+        ("rust-indexmap" ,rust-indexmap-2)
+        ("rust-indoc" ,rust-indoc-2)
+        ("rust-inventory" ,rust-inventory-0.3)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-memoffset" ,rust-memoffset-0.9)
+        ("rust-num-bigint" ,rust-num-bigint-0.4)
+        ("rust-num-complex" ,rust-num-complex-0.4)
+        ("rust-parking-lot" ,rust-parking-lot-0.12)
+        ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.20)
+        ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.20)
+        ("rust-pyo3-macros" ,rust-pyo3-macros-0.20)
+        ("rust-rust-decimal" ,rust-rust-decimal-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-either" ,rust-either-1)
+        ("rust-unindent" ,rust-unindent-0.2))
+       #:cargo-development-inputs
+       (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-proptest" ,rust-proptest-1)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-send-wrapper" ,rust-send-wrapper-0.6)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-trybuild" ,rust-trybuild-1)
+        ("rust-widestring" ,rust-widestring-0.5))))
+    (inputs (list python))
+    (home-page "https://github.com/pyo3/pyo3")
+    (synopsis "Rust bindings for the Python interpreter")
+    (description
+     "This package provides Rust bindings for Python, including tools for
+creating native Python extension modules.  Running and interacting with
+Python code from a Rust binary is also supported.")
+    (license license:asl2.0)))
+
 (define-public rust-pyo3-0.19
   (package
+    (inherit rust-pyo3-0.20)
     (name "rust-pyo3")
     (version "0.19.2")
     (source (origin
@@ -59196,15 +59251,7 @@  (define-public rust-pyo3-0.19
         ("rust-serde" ,rust-serde-1)
         ("rust-serde-json" ,rust-serde-json-1)
         ("rust-trybuild" ,rust-trybuild-1)
-        ("rust-widestring" ,rust-widestring-0.5))))
-    (inputs (list python))
-    (home-page "https://github.com/pyo3/pyo3")
-    (synopsis "Rust bindings for the Python interpreter")
-    (description
-     "This package provides Rust bindings for Python, including tools for
-creating native Python extension modules.  Running and interacting with
-Python code from a Rust binary is also supported.")
-    (license license:asl2.0)))
+        ("rust-widestring" ,rust-widestring-0.5))))))
 
 (define-public rust-pyo3-0.18
   (package