diff mbox series

[bug#69048,28/32] gnu: Add python-annotated-types.

Message ID 962d69ba9cbbda74911c39dac75bb1281244c99a.1707650794.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add python-pydantic v2 and required rust and python packages | expand

Commit Message

Hartmut Goebel Feb. 11, 2024, 11:43 a.m. UTC
* gnu/packages/python-xyz.scm (python-annotated-types): New variable.
---
 gnu/packages/python-xyz.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c68b17b0ab..b4b69e0f3f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
-;;; Copyright © 2016, 2018, 2019, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2018, 2019, 2021, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
@@ -27881,6 +27881,29 @@  (define-public python-toolshed
 functions that aim to reduce boilerplate when working with data.")
     (license license:bsd-2)))
 
+(define-public python-annotated-types
+  (package
+    (name "python-annotated-types")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "annotated_types" version))
+       (sha256
+        (base32 "0paaz0i4xqk335ji5w887i2bhgm2krnzr6by4sfgsgz50zl3jcsn"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-hatchling python-pytest))
+    (propagated-inputs (list python-typing-extensions))
+    (home-page "https://github.com/annotated-types/annotated-types")
+    (synopsis "Reusable constraint types to use with typing.Annotated")
+    (description "This package provides metadata objects which can be used to
+represent common constraints such as upper and lower bounds on scalar values
+and collection sizes, a Predicate marker for runtime checks, and descriptions
+of how we intend these metadata to be interpreted.  In some cases, we also
+note alternative representations which do not require this package.")
+    (license license:expat)))
+
 (define-public python-annoy
   (package
     (name "python-annoy")