diff mbox series

[bug#60838,v3,6/9] gnu: Add python-trustme-next.

Message ID e20b4a5848c04549aba1a1d73e40e022f578e1f3.1679859198.git.felgru@posteo.net
State New
Headers show
Series Add datasette and python-sqlite-utils. | expand

Commit Message

Felix Gruber March 26, 2023, 7:43 p.m. UTC
* gnu/packages/python-crypto.scm (python-trustme-next): New variable.
---
 gnu/packages/python-crypto.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c9071c4cf6..134b59427d 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1536,6 +1537,20 @@  (define-public python-trustme
     ;; Either license applies.
     (license (list license:expat license:asl2.0))))
 
+;;; TODO: Make this the default python-trustme in the next rebuild cycle.
+(define-public python-trustme-next
+  (package
+    (inherit python-trustme)
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trustme" version))
+       (sha256
+        (base32 "0v2qzszmyazfgc1snicdr4b4qdajpjd4pbinpgrn9vfff0yv41sy"))))
+    (propagated-inputs
+     (list python-cryptography python-idna python-ipaddress))))
+
 (define-public python-certipy
   (package
     (name "python-certipy")