diff mbox series

[bug#60838,v3,8/9] gnu: python-pytest-7.1: Depend on python-pluggy-next.

Message ID 77ffe169da72ad2619e6089130ce53f36904a155.1679859198.git.felgru@posteo.net
State New
Headers show
Series Add datasette and python-sqlite-utils. | expand

Commit Message

Felix Gruber March 26, 2023, 7:43 p.m. UTC
* gnu/packages/check.scm (python-pytest-7.1)[propagated-inputs]: Replace
  python-pluggy with python-pluggy-next.
---
 gnu/packages/check.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0c8777a074..03b5828efc 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1326,7 +1326,11 @@  (define-public python-pytest-7.1
         #~(modify-phases #$phases
             (add-before 'build 'pretend-version
               (lambda _
-                (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))))
+                (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))
+    (propagated-inputs
+      (modify-inputs (package-propagated-inputs python-pytest)
+                     (replace "python-pluggy" python-pluggy-next)))
+    ))
 
 (define-public python-pytest-bootstrap
   (package