diff mbox series

[bug#60838,v3,7/9] gnu: Add python-cogapp.

Message ID 2158579b7a9f6c745993ee26d7adee9a517aee61.1679859198.git.felgru@posteo.net
State New
Headers show
Series Add datasette and python-sqlite-utils. | expand

Commit Message

Felix Gruber March 26, 2023, 7:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-cogapp): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9240fad2e6..391a75e341 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31583,6 +31583,28 @@  (define-public python-geomet
 versa.  Extended WKB/WKT are also supported.")
     (license license:asl2.0)))
 
+(define-public python-cogapp
+  (package
+    (name "python-cogapp")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cogapp" version))
+              (sha256
+               (base32
+                "1c0xx3p3lzrlyqhmccyq9c50f8v9pqk2992gb4nl50h2yy1m3s8v"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f))
+    (home-page "http://nedbatchelder.com/code/cog")
+    (synopsis
+     "Content generator for executing Python snippets in source files")
+    (description
+     "Cog is a file generation tool. It lets you use pieces of Python
+code as generators in your source files to generate whatever text you
+need.")
+    (license license:expat)))
+
 (define-public python-bsdiff4
   (package
     (name "python-bsdiff4")