diff mbox series

[bug#60838,v3,1/9] gnu: Add python-click-default-group-wheel.

Message ID 2a7b8740b269e302ca20194e10eeeb763094b1cc.1679859197.git.felgru@posteo.net
State New
Headers show
Series Add datasette and python-sqlite-utils. | expand

Commit Message

Felix Gruber March 26, 2023, 7:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-click-default-group-wheel): New
  variable.
---
 gnu/packages/python-xyz.scm | 26 +++++++++++++++++++++++++-
 1 file changed, 25 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f0005faa2..9240fad2e6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -108,7 +108,7 @@ 
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2021 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 ;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
-;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
@@ -14964,6 +14964,30 @@  (define-public python-click-default-group
     (home-page "https://github.com/click-contrib/click-default-group")
     (license license:bsd-3)))
 
+(define-public python-click-default-group-wheel
+  ;; Fork of python-click-default-group used by sqlite-utils and datasette.
+  ;; See https://github.com/click-contrib/click-default-group/issues/21
+  (package
+    (name "python-click-default-group-wheel")
+    (version "1.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "click-default-group-wheel" version))
+              (sha256
+               (base32
+                "0ivpdng2391v8afd5j1xdv9vbbr9iafbdh6h5shqhgn0j8ns83g9"))))
+    (build-system python-build-system)
+    (arguments
+      '(#:tests? #f)) ; no tests in pypi package
+    (propagated-inputs (list python-click))
+    (home-page "https://github.com/sublee/click-default-group/")
+    (synopsis "Python extension for the @code{click.Group} class")
+    (description
+      "DefaultGroup is a subclass of @code{click.Group} which invokes a
+default sub-command instead of showing a help message when a sub-command
+is not passed.")
+    (license license:bsd-3)))
+
 (define-public python-structlog
   (package
     (name "python-structlog")