diff mbox series

[bug#65939,10/33] gnu: Add go-github-com-u-root-uio.

Message ID e093df42a4b623596020a88d19a0f8c1760f387a.1694676586.git.edk@beaver-labs.com
State New
Headers show
Series [bug#65939,01/33] gnu: Add go-github-com-sourcegraph-go-lsp. | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:29 a.m. UTC
* gnu/packages/golang.scm (go-github-com-u-root-uio): New variable.
---
 gnu/packages/golang.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 05c81b56bb..0e6d0d1adb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13350,6 +13350,37 @@  (define-public go-github-com-josharian-native
     (description "Package native provides easy access to native byte order.")
     (license license:expat)))
 
+(define-public go-github-com-u-root-uio
+  (package
+    (name "go-github-com-u-root-uio")
+    (version "0.0.0-20230305220412-3e8cd9d6bf63")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/u-root/uio")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gvv66ixkgwikjx8sjdknvrmd08wv2ia02q8n8y3mnkhrgyyx1yf"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/u-root/uio/uio"
+       #:unpack-path "github.com/u-root/uio/"
+       #:tests? #f;;The tests fail because of go-github-com-pierrec-lz4-v4 but
+       ;; the output make it seem that test is broken, not the code.  The
+       ;; output looks like "Got something, want something else", but
+       ;; something and something else look pretty much the same (at a cursory
+       ;; glance). I'll move on as I don't think this has an actual impact.
+       ))
+    (propagated-inputs `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-github-com-pierrec-lz4-v4" ,go-github-com-pierrec-lz4-v4)
+                         ("go-github-com-josharian-native" ,go-github-com-josharian-native)))
+    (home-page "https://github.com/u-root/uio")
+    (synopsis "uio")
+    (description #f)
+    (license license:bsd-3)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")