diff mbox series

[bug#65939,31/33] gnu: Add go-github-com-netflix-go-expect.

Message ID 9bc6f5b0d10a462ff7eaa6f2ab38abea006b0da1.1694676586.git.edk@beaver-labs.com
State New
Headers show
Series [bug#65939,01/33] gnu: Add go-github-com-sourcegraph-go-lsp. | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:29 a.m. UTC
* gnu/packages/golang.scm (go-github-com-netflix-go-expect): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 64c2964aa7..fefc127e9d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13842,6 +13842,33 @@  (define-public go-github-com-shurcool-go-importgraphutil
     (description "Common Go code.")
     (license license:expat)))
 
+(define-public go-github-com-netflix-go-expect
+  (package
+    (name "go-github-com-netflix-go-expect")
+    (version "0.0.0-20220104043353-73e0943537d2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Netflix/go-expect")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0zkvhnc4ii6ygvcsj54ng0kql26rnny7l3hy1w61g88mxjsww1b9"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/Netflix/go-expect"))
+    (propagated-inputs `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+                         ("go-github-com-creack-pty" ,go-github-com-creack-pty)))
+    (home-page "https://github.com/Netflix/go-expect")
+    (synopsis "go-expect")
+    (description
+     "Package expect provides an expect-like interface to automate control of
+applications.  It is unlike expect in that it does not spawn or manage process
+lifecycle.  This package only focuses on expecting output and sending input
+through it's psuedoterminal.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-inconshreveable-mousetrap
   (package
     (name "go-github-com-inconshreveable-mousetrap")