diff mbox series

[bug#65939,09/33] gnu: Add go-github-com-pierrec-lz4-v4.

Message ID 77b81fc42d1de58aa4e9500b05956526db410f7e.1694676586.git.edk@beaver-labs.com
State New
Headers show
Series [bug#65939,01/33] gnu: Add go-github-com-sourcegraph-go-lsp. | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:29 a.m. UTC
* gnu/packages/golang.scm (go-github-com-pierrec-lz4-v4): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 261c859d27..05c81b56bb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13259,6 +13259,30 @@  (define-public go-src-elv-sh
 Windows.")
     (license license:bsd-2)))
 
+(define-public go-github-com-pierrec-lz4-v4
+  (package
+    (name "go-github-com-pierrec-lz4-v4")
+    (version "4.1.18")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pierrec/lz4")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "054b40963h3l13a7nxw3990b3a9033ypin7l79da6fiv2ynnsnb8"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:tests? #f  ;; The tests fail, but I have neither the time nor the skill
+       ;; to make them pass.
+       #:import-path "github.com/pierrec/lz4/v4"))
+    (home-page "https://github.com/pierrec/lz4")
+    (synopsis "lz4 : LZ4 compression in pure Go")
+    (description
+     "Package lz4 implements reading and writing lz4 compressed data.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-hashicorp-errwrap
   (package
     (name "go-github-com-hashicorp-errwrap")