diff mbox series

[bug#65939,17/33] gnu: Add go-github-com-klauspost-pgzip.

Message ID bd485f957c7f72565b8fda204d2d5a42b0f845cf.1694676586.git.edk@beaver-labs.com
State New
Headers show
Series [bug#65939,01/33] gnu: Add go-github-com-sourcegraph-go-lsp. | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:29 a.m. UTC
* gnu/packages/golang.scm (go-github-com-klauspost-pgzip): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 075f341b9b..f2924ae796 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12015,6 +12015,31 @@  (define-public go-github-com-klauspost-compress
     (description "@code{compress} provides various compression algorithms.")
     (license license:bsd-3)))
 
+(define-public go-github-com-klauspost-pgzip
+  (package
+    (name "go-github-com-klauspost-pgzip")
+    (version "1.2.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/klauspost/pgzip")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j29wr6nd9ncdbkjphyziv0h8p5s2mj222cgcfqxmzjnfn7623d8"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/klauspost/pgzip"))
+    (propagated-inputs
+     (list go-github-com-klauspost-compress))
+    (home-page "https://github.com/klauspost/pgzip")
+    (synopsis "pgzip")
+    (description
+     "Package pgzip implements reading and writing of gzip format compressed files, as
+specified in @@url{https://rfc-editor.org/rfc/rfc1952.html,RFC 1952}.")
+    (license license:expat)))
+
 (define-public go-github-com-oneofone-xxhash
   (package
     (name "go-github-com-oneofone-xxhash")