[bug#75127,v8,09/44] gnu: Add rust-self-replace-1.

Message ID e093b06763942b716a2b506e5c0d631bd805ab6e.1738779575.git.herman@rimm.ee
State New
Headers
Series Add cargo-nextest. |

Commit Message

Herman Rimm Feb. 5, 2025, 6:31 p.m. UTC
  From: Jordan Moore <lockbox@struct.foo>

* gnu/packages/crates-io.scm (rust-self-replace-1): New variable.

Change-Id: I89968eb1bf67938f3473a755b82f9f73e35cab17
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 70d30d75eeb..85391f48ced 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69807,6 +69807,30 @@  (define-public rust-self-cell-1
 in stable Rust.")
     (license license:asl2.0)))
 
+(define-public rust-self-replace-1
+  (package
+    (name "rust-self-replace")
+    (version "1.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "self-replace" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1drganasvf5b0x6c9g60jkfhzjc9in3r6cznjfw0lhmbbrdq3v03"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ;crate does not package test dependencies
+       #:cargo-inputs (("rust-fastrand" ,rust-fastrand-2)
+                       ("rust-tempfile" ,rust-tempfile-3)
+                       ("rust-windows-sys" ,rust-windows-sys-0.52))))
+    (home-page "https://github.com/mitsuhiko/self-replace")
+    (synopsis "Allow executables to replace or uninstall themselves")
+    (description
+     "This package provides an utility crate that allows executables to
+replace or uninstall themselves.")
+    (license license:asl2.0)))
+
 (define-public rust-selinux-0.4
   (package
     (name "rust-selinux")