[bug#75127,v8,35/44] gnu: Add rust-debug-ignore-1.

Message ID 8d80183b89cc4ef935df42f129bf092197bbd52a.1738779577.git.herman@rimm.ee
State New
Headers
Series Add cargo-nextest. |

Commit Message

Herman Rimm Feb. 5, 2025, 6:31 p.m. UTC
  From: Jordan Moore <lockbox@struct.foo>

* gnu/packages/crates-io.scm (rust-debug-ignore-1): New variable.

Change-Id: Ia30df0f8425b0c3776710e1f81a6231e21f353bb
---
 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b826af12551..3d3161f3a4c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19437,6 +19437,28 @@  (define-public rust-debug-helper-0.3
 the Debug trait manually.")
     (license license:expat)))
 
+(define-public rust-debug-ignore-1
+  (package
+    (name "rust-debug-ignore")
+    (version "1.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "debug-ignore" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "08gwdny6124ggy4hyli92hdyiqc5j2z9lqhbw81k0mgljcfyvrzz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/sunshowers-code/debug-ignore")
+    (synopsis "Newtype to skip a field while printing Debug output")
+    (description
+     "This package provides a newtype wrapper that causes a field to be
+skipped while printing out Debug output.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-debug-unreachable-0.1
   (package
     (name "rust-debug-unreachable")