[bug#75127,v8,11/44] gnu: Add rust-structmeta-derive-0.3.

Message ID 378b8b21e6d4f0ca602c8724ca3282faa5cf19c4.1738779575.git.herman@rimm.ee
State New
Headers
Series Add cargo-nextest. |

Commit Message

Herman Rimm Feb. 5, 2025, 6:31 p.m. UTC
  From: Jordan Moore <lockbox@struct.foo>

* gnu/packages/crates-io.scm (rust-structmeta-derive-0.3): New variable.
(rust-structmeta-derive-0.2): Inherit rust-structmeta-derive-0.3.

Change-Id: Ice4007124f9325337e6259c3ebea317f5d89f737
---
 gnu/packages/crates-io.scm | 27 ++++++++++++++++++++++-----
 1 file changed, 22 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 98080ff85d5..d18c3827bcc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -76763,29 +76763,46 @@  (define-public rust-structmeta-0.1
         ("rust-structmeta-derive" ,rust-structmeta-derive-0.1)
         ("rust-syn" ,rust-syn-1))))))
 
-(define-public rust-structmeta-derive-0.2
+(define-public rust-structmeta-derive-0.3
   (package
     (name "rust-structmeta-derive")
-    (version "0.2.0")
+    (version "0.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "structmeta-derive" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "005ybz4ha874w81pg15n00p01m9hir1dpl8p0352s1wpfgzwl2x6"))))
+        (base32 "1z12r4v2d3272hxqxclnr1kn2kp07qsy5aswm4ynrzwhlmjhnahm"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
                        ("rust-quote" ,rust-quote-1)
-                       ("rust-syn" ,rust-syn-2))
-       #:cargo-development-inputs (("rust-syn" ,rust-syn-2))))
+                       ("rust-syn" ,rust-syn-2))))
     (home-page "https://github.com/frozenlib/structmeta")
     (synopsis "Derive macro for structmeta crate")
     (description
      "This package provides a derive macro for the structmeta crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-structmeta-derive-0.2
+  (package
+    (inherit rust-structmeta-derive-0.3)
+    (name "rust-structmeta-derive")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "structmeta-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "005ybz4ha874w81pg15n00p01m9hir1dpl8p0352s1wpfgzwl2x6"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2))))))
+
 (define-public rust-structmeta-derive-0.1
   (package
     (inherit rust-structmeta-derive-0.2)