diff mbox series

[bug#57540,6/6] gnu: Add coq-mathcomp-bigenough and coq-mathcomp-analysis.

Message ID e034d85426248aa93e3a8a1c0609d1e6@disroot.org
State Accepted
Headers show
Series [bug#57540] Add ocaml-elpi (a dependency of coq-mathcomp-analysis) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Garek Dyszel Sept. 2, 2022, 3:25 p.m. UTC
* gnu/packages/coq.scm (coq-mathcomp-bigenough coq-mathcomp-analysis)
---
  gnu/packages/coq.scm | 105 +++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 105 insertions(+)

+     "This repository contains an experimental library for
+real analysis for the Coq proof-assistant, using the Mathematical
+Components library.")
+    (home-page "https://math-comp.github.io/")
+    (license license:cecill-c)))
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index f0aa233..680c2fa 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -869,3 +869,108 @@  (define-public coq-mathcomp-finmap
  subsume notations for finite sets.")
      (home-page "https://math-comp.github.io/")
      (license license:cecill-b)))
+
+(define-public coq-mathcomp-bigenough
+  ;; On the homepage, it is mentioned that coq-mathcomp-bigenough
+  ;; is going to be obsolete sometime in the near future.
+  ;; This package was included because of the following error,
+  ;; encountered while building coq-mathcomp-analysis:
+  ;; "Warning: in file theories/altreals/realseq.v, library
+  ;; mathcomp.bigenough.bigenough is required and has not been
+  ;; found in the loadpath!"
+  ;; So added https://github.com/math-comp/bigenough.
+  (package
+    (name "coq-mathcomp-bigenough")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/math-comp/bigenough")
+                    (commit version)
+                    (recursive? #t)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                
"02f4dv4rz72liciwxb2k7acwx6lgqz4381mqyq5854p3nbyn06aw"))))
+    (build-system gnu-build-system)
+    (arguments
+     `( ;"No rule to make target 'test'. Stop."
+       ;; No references to tests in Makefile.common.
+       #:tests? #f
+       #:make-flags ,#~(list (string-append "COQBIN="
+                                            #$(this-package-input 
"coq-core")
+                                            "/bin/")
+                             (string-append "COQMF_COQLIB="
+                                            (assoc-ref %outputs "out")
+                                            "/lib/ocaml/site-lib/coq")
+                             (string-append "COQLIBINSTALL="
+                                            (assoc-ref %outputs "out")
+                                            "/lib/coq/user-contrib"))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))))
+    (propagated-inputs (list coq coq-core coq-mathcomp which))
+    (home-page "https://math-comp.github.io/")
+    (synopsis "Small library to do epsilon - N reasoning")
+    (description
+     "The package contains a package to reasoning with big enough
+objects (mostly natural numbers).  This package is essentially for
+backward compatibility purposes as `bigenough` will be subsumed by the
+near tactics.  The formalization is based on the Mathematical
+Components library.")
+    (license license:cecill-b)))
+
+(define-public coq-mathcomp-analysis
+  (package
+    (name "coq-mathcomp-analysis")
+    (version "0.5.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/math-comp/analysis")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                
"16bv2kxm6nrgfm9lp88sls1vqs26d4m3fxbccmy328ak5srcbn6l"))))
+    (build-system gnu-build-system)
+    (arguments
+     `( ;No tests were supplied with this library:
+       ;; No rule to make target 'check'. Stop.
+       ;; Makefile.common has no references to tests at all
+       ;; (yet).
+       #:tests? #f
+       #:make-flags ,#~(list (string-append "COQBIN="
+                                            #$(this-package-input 
"coq-core")
+                                            "/bin/")
+                             (string-append "COQBININSTALL="
+                                            (assoc-ref %outputs "out") 
"/bin/")
+                             (string-append "DESTDIR="
+                                            (assoc-ref %outputs "out"))
+                             (string-append "COQMF_COQLIB="
+                                            (assoc-ref %outputs "out")
+                                            "/lib/ocaml/site-lib/coq")
+                             (string-append "COQLIBINSTALL="
+                                            (assoc-ref %outputs "out")
+                                            "/lib/coq/user-contrib"))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (replace 'build
+                    (lambda* (#:key make-flags #:allow-other-keys)
+                      (apply invoke "make" "build" make-flags))))))
+    (inputs (list coq
+                  coq-stdlib
+                  coq-mathcomp
+                  coq-mathcomp-finmap
+                  coq-mathcomp-hierarchy-builder
+                  coq-elpi-1.14
+                  coq-mathcomp-bigenough
+                  coq-core
+                  which
+                  python))
+    (synopsis "Real analysis for the Coq proof assistant")
+    (description