diff mbox series

[bug#57540,5/6] gnu: Add coq-mathcomp-finmap.

Message ID d078c5f6e7a20b07c0867acad0d944b7@disroot.org
State Accepted
Headers show
Series [bug#57540] Add ocaml-elpi (a dependency of coq-mathcomp-analysis) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Garek Dyszel Sept. 2, 2022, 3:24 p.m. UTC
* gnu/packages/coq.scm (coq-mathcomp-finmap)
---
  gnu/packages/coq.scm | 35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)

+contains a generic order and set libary, which will eventually be used 
to
+subsume notations for finite sets.")
+    (home-page "https://math-comp.github.io/")
+    (license license:cecill-b)))
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index bb4788a..f0aa233 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -834,3 +834,38 @@  (define-public coq-mathcomp-hierarchy-builder
      (home-page "https://math-comp.github.io/")
      ;; MIT license
      (license license:expat)))
+
+(define-public coq-mathcomp-finmap
+  (package
+    (name "coq-mathcomp-finmap")
+    (version "1.5.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/math-comp/finmap")
+                    (commit version)
+                    (recursive? #t)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                
"1k72wpp15xa5ag358jl8a71gschng0bgbaqjx0l5a0in6x5adafh"))))
+    (build-system gnu-build-system)
+    (arguments
+     `( ;"No rule to make target 'check'."
+       ;; No tests supplied in Makefile.common.
+       #:tests? #f
+       #:make-flags (list (string-append "COQLIBINSTALL="
+                                         (assoc-ref %outputs "out")
+                                         "/lib/coq/user-contrib"))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))))
+    (inputs (list coq coq-stdlib coq-mathcomp which))
+    (synopsis "Finite sets and finite types for coq-mathcomp")
+    (description
+     "This library is an extension of coq-mathcomp which supports 
finite sets
+and finite maps on choicetypes (rather than finite types).  This 
includes
+support for functions with finite support and multisets.  The library 
also